Server Not Launching

Server Help/Discussion.
Post Reply
goirdin
Vertex
Vertex
Posts: 15
Joined: Sun Mar 21, 2010 8:11 pm

Server Not Launching

Post by goirdin » Fri Aug 05, 2011 7:32 am

I know I've done something wrong, but I just can't tell what. The second I launch the server with the batch file:
"D:\Program Files\Srcds\orangebox\srcds.exe" -console -game obsidian -port 27015 +map oc_lobby +maxplayers 4 +sv_lan 0 +heartbeat
The command prompt will appear for a second, then disappear. I've run Obsidian Conflict servers before, and I remember fixing this error, but I can't, for the like of me, remember how. What am I doing wrong?
In the folder D:\Program Files\Srcds\orangebox I've got bin, cstrike, ep2, episodic, hl1, hl2, obsidian, and platform. The obsidian is a newly installed version too. I extracted all the GCF files and did everything right up to this point, but I can't launch the server.

User avatar
TESLA-X4
Level 10 Bug Hunter
Level 10 Bug Hunter
Posts: 572
Joined: Wed Jul 01, 2009 3:26 pm
Location: $Recycle.Bin

Re: Server Not Launching

Post by TESLA-X4 » Fri Aug 05, 2011 8:52 am

I guess it's probably too late at this point, but I think you're running into this issue.
You could try replacing the engine binaries (the files inside the orangebox/bin folder) with the ones in this post.
Apparently, Valve can't make games beyond the number 2.
I think the only time we'll get a Source SDK code update is when it starts having purchasable hats integrated, i.e. hatconomy.

Please do not make assumptions you are not knowledgeable enough to make - that just backfires on yourself.
Tick me off, and I'll be sure to give you the golden treatment. Haven't you heard? Silence is golden.

goirdin
Vertex
Vertex
Posts: 15
Joined: Sun Mar 21, 2010 8:11 pm

Re: Server Not Launching

Post by goirdin » Fri Aug 05, 2011 9:19 am

I'm not sure what "this issue" is, installing games using HLDS update tool after installing orangebox? I don't think that's related to my problem, as it said you can get an error if that happens. I don't get an error, my CMD just closes right after starting the batch file.

User avatar
TESLA-X4
Level 10 Bug Hunter
Level 10 Bug Hunter
Posts: 572
Joined: Wed Jul 01, 2009 3:26 pm
Location: $Recycle.Bin

Re: Server Not Launching

Post by TESLA-X4 » Fri Aug 05, 2011 10:59 am

goirdin wrote:I'm not sure what "this issue" is, installing games using HLDS update tool after installing orangebox?
Yep, that's exactly what I'm getting at because it's the most common problem by far.
goirdin wrote:I don't think that's related to my problem, as it said you can get an error if that happens. I don't get an error, my CMD just closes right after starting the batch file.
Well, it still wouldn't hurt to try this to be sure that it's not the cause of the problem. Also, are you running any server plugins such as Metamod: Source or SourceMod?
You could also check if you have performed this step.
The lack of an error message is making this issue rather hard to diagnose.
Apparently, Valve can't make games beyond the number 2.
I think the only time we'll get a Source SDK code update is when it starts having purchasable hats integrated, i.e. hatconomy.

Please do not make assumptions you are not knowledgeable enough to make - that just backfires on yourself.
Tick me off, and I'll be sure to give you the golden treatment. Haven't you heard? Silence is golden.

goirdin
Vertex
Vertex
Posts: 15
Joined: Sun Mar 21, 2010 8:11 pm

Re: Server Not Launching

Post by goirdin » Sat Aug 06, 2011 12:11 am

I just assumed there was something wrong with the batch file, as the CMD can do that if you have an improper batch file. But I believe that I did install counter strike after orangebox. That's what the tutorial says to do on the page though, it says:

"This will download Orangebox content so it sets up your directories. While your at it, download "Counter-Strike Source" content as well. Just replace the "orangebox" with "Counter-Strike Source" and run the bat again."

So that's what I did, I installed orangebox, then counter strike. So I'm guessing that's the problem? What should I do to fix it, install counter strike first? And yes, When copying the obsidian folder to orangebox, I used the "Server Install" instead of "Client Install" which had sourcemod in it. I assumed that was the only difference as the server install had .1 more MB's or something tiny like that, but could that have been the problem? So yes, sourcemod is on it as well. Thanks for the help, I really appreciate it.

User avatar
TESLA-X4
Level 10 Bug Hunter
Level 10 Bug Hunter
Posts: 572
Joined: Wed Jul 01, 2009 3:26 pm
Location: $Recycle.Bin

Re: Server Not Launching

Post by TESLA-X4 » Sat Aug 06, 2011 4:14 am

The problem is that most of the Valve games are now on Source Engine 2009, so if you download 'orangebox' and later download any other game resources, your engine binaries will also be updated to Source Engine 2009, which this mod (and all other Source mods, for that matter) are incompatible with. Most Source mods (sans Garry's Mod) still run on Source Engine 2007 because Valve still hasn't released Source SDK Base 2009 and other related code.

To avoid it, you should rename your 'orangebox/bin' folder to something else (e.g. bin_se2007) immediately after 'orangebox' completes downloading. Of course, this is no use if you have already downloaded other Valve games with hldsupdatetool.exe.

To remedy it, you have two options:
1) Delete the whole 'orangebox/bin' folder, then run:

Code: Select all

hldsupdatetool -command update -dir C:\server\orangebox -game "orangebox"
*** Don't forget to change the dir path to match your own setup!
The engine binaries for Source 2007 should be downloaded after that.

2) Download the binaries from here and overwrite the files in 'orangebox/bin'.
Apparently, Valve can't make games beyond the number 2.
I think the only time we'll get a Source SDK code update is when it starts having purchasable hats integrated, i.e. hatconomy.

Please do not make assumptions you are not knowledgeable enough to make - that just backfires on yourself.
Tick me off, and I'll be sure to give you the golden treatment. Haven't you heard? Silence is golden.

goirdin
Vertex
Vertex
Posts: 15
Joined: Sun Mar 21, 2010 8:11 pm

Re: Server Not Launching

Post by goirdin » Sat Aug 06, 2011 7:19 am

Thank you so much, I tried your first option and it worked. Now I'm running into the error of "MasterRequestRestart
Your server is out of date. Please update and restart."
I remember getting this error earlier and fixing it quite easily, but I don't remember how now. Any ideas?

User avatar
Neico
Lead Coder
Lead Coder
Posts: 1811
Joined: Tue Aug 15, 2006 3:39 pm
Location: Germany
Contact:

Re: Server Not Launching

Post by Neico » Sat Aug 06, 2011 7:26 am

I might remind you that you don't need to replace any engine dll's when you use -game "orangebox", just make sure not to use anything else like tf2 css or dod which would place the wrong bin folder...

and to that outdated thing, read the stickys in here...

Post Reply