[SourceMod | Deprecated] Illegal Model Fix 1.0.0

This Section is all about Coding in C/C++ / Lua / SourcePawn for now...
Post Reply
User avatar
TESLA-X4
Level 10 Bug Hunter
Level 10 Bug Hunter
Posts: 595
Joined: Wed Jul 01, 2009 3:26 pm
Location: $Recycle.Bin

[SourceMod | Deprecated] Illegal Model Fix 1.0.0

Post by TESLA-X4 » Thu Jul 28, 2011 4:38 pm

This plugin is deprecated, if you have already installed this hotfix, you do not need to install this plugin.

An exploit that allows players to change their player model to arbitrary models has recently been reported. Since the next version of Obsidian Conflict is not yet ready for release, this hotfix should hold until then. I encourage all server operators running SourceMod to install this hotfix. If you have already installed Model Reservation 1.0.1.1, you do not need to install this hotfix.

Configuration:
None.

Commands & Console Variables:
None (except for version ConVar).

Dependencies:
None.

Installation:
Place modelfix.smx into the /sourcemod/plugins directory.

Changelog:

Code: Select all

Version 1.0.0
-----------------------
Initial release
Notes:
In case you haven't already noticed, this is a plugin for server operators, not clients.

Known Bugs/Limitations/Future Improvements:
None at this time.

Credits:
- Dr Headhumper for making the bug report

Download:
Get Plugin or Get Source
Apparently, Valve can't make games beyond the number 2.
I think the only time we'll get a Source SDK code update is when it starts having purchasable hats integrated, i.e. hatconomy.

Please do not make assumptions you are not knowledgeable enough to make - that just backfires on yourself.
Tick me off, and I'll be sure to give you the golden treatment. Haven't you heard? Silence is golden.

Post Reply